Custom Community issues with BuddyPress 1.6

Thanks to the Community feedback – we are now aware of the most incompatibility problems in Custom Community with BuddyPress 1.6 and we want to let you know that we are working on the issues and will provide you with a new version which supports BP 1.6 next week.

If you find any bugs please report it here. Or in the BuddyPress forum in this Topic.

Sorry for your discomfort,
 
your Themekraft Team

  1. c0rp53 says:

    Hi there, first of all, the important information:

    * Running: *WordPress 3.4.1.

    * Buddypress 1.6, upgraded from 1.5.7, everything was working just fine before upgrade.

    * Custom Community Theme (child).

    Now my issue:

    I’m getting this error when I’m try to access some profile tabs,

    Fatal error: Cannot access empty property in /home/pgandita/public_html/loksearte.org/wp-content/plugins/buddypress/bp-core/bp-core-template.php on line 787

    The tabs which aren’t working are: Achievements (Achievements for buddypress plugin), Projects (Portfolio plugin), Profile/change background (BP Custom Background for User Profile plugin),Settings and Settings/Notifications aren’t working neither.. Also, the wordpress bar disapear when I navegate to any user’s profile and those tabs which aren’t working.

    Greetings from Chile and apologize me for my bad english!

  2. Avatar of svenl77

    svenl77 says:

    Hi @c0rp53,

    thanks for reporting, I just answered in the BuddyPress Forum.

    If you write us a short mail to support [at] themekraft [dot] com with your wp-admin credentials, then we can have a look at your installation and maybe find out more.

    Please have a look into this thread for help: http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/post-update-and-members-directory-not-working-after-upgrade-to-1-6/?#post-135716

    Cheers, Sven

    • c0rp53 says:

      Alright, thanks for answering. I’m not sure what do you mean by wp-admin credentials, I assume it is an admin account and that’s what I’ll send you via mail. Also, I would like to let you know that since 1.6.1 the error persists but changed it line

      Fatal error: Cannot access empty property in /home/pgandita/public_html/loksearte.org/wp-content/plugins/buddypress/bp-core/bp-core-template.php on line 823

      Greeetings

  3. saukgp says:

    still facing the bug, after the buddypress update 1.6, we are unable to access the site via mobile wap. the activity comment button is not working, please help to fix this, am using custom community version 1.8.9.1

    • Avatar of konrads

      konrads says:

      please deactivate all plugins except buddypress and always check in between if the error still exists… i’m sure it’s a plugin conflict. please write further to support [at] themekraft [dot] com… As comments are a bad place for support :) Thanks for your help, we’ll find it out!

  4. Avatar of thecitizen

    thecitizen says:

    Ok so I setup a test site (highly encourage everyone to have one) in order to minimize disruption with my site while I tested everything… and found it all works perfectly. I have to assume it is some kind of damage caused by a previous plugin (possibly the previous membership plugin or the caching plugin) i was using before. I ended up migrating my site to the fresh site and it all works.

    I would backup your entire site + DB before upgrading ANY of the major items of your site like: WP, bbpress, buddypress, custom community,and s2member. If possible have a dummy site setup identically for testing.

  5. > R V I says:

    The bubble for the general settings default homepage post style in the CC 1.9.1 free version is gone, the option is still there ..

  6. brock says:

    Wow. Saw the upgrade to the free version and installed. Ran it in the test mode, looked OK. Activated…

    Server error
    The website encountered an error while retrieving http://www.acutance.net/wp-admin/themes.php. It may be down for maintenance or configured incorrectly.
    Here are some suggestions:
    Reload this web page later.
    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfil the request.

    Renamed the theme directory – no error, just blank page!

    Not good. Locked out! Auughh!

    • Avatar of konrads

      konrads says:

      Sounds like a server error and not theme related – and regarding the theme directory, you can never rename it! ;)

      If you still run into other theme related problems please write an email to support [at] themekraft [dot] com to get help. Comments is not good for supporting :)

      Hope this helps, Konrad

  7. Dmitriy says:

    Hi to all.
    I am using WordPress 3.4.2, BP 1.6.1, Custom Community 1.9.1 free.
    I have registered a new user. I’m trying to activate it using the link in the email.
    I go on the link and I get back to the registration page.

    Debug info:
    Undefined property: stdClass::$id in /wp-content/themes/custom-community/core/includes/tkf/wp/detect.php on line 116
    P Notice: Undefined variable: user_login in /wp-content/themes/custom-community/core/includes/wp/widgets.php on line 139

  8. Amal says:

    Hi all,

    I’m using WP 3.5, BP 1.6 and Custom Community 1.10 free version.

    I have this minor issue which was existed also with WP 3.4:
    The Visibility options of the profile fields (Anyone, Logged In Users, My Friends) are always visible in “Edit Profile” page, while the default behavior is to be hidden till you click the “Change” link next to the field.

    What can be done to retrieve the default behavior?

    Thanks
    Amal

  9. Amal says:

    Hi Konrad,

    I have a question plz: If I wanted to stick with WP 3.4 for now till I assure that all the plugins + theme I’m using is 100% compatible with WP 3.5, what can I modify (on the Custom Community 1.10 free version) to solve the “Visibility options” issue?

    Your help is appreciated :) Have a nice day!

  10. Amal says:

    Hi Konrad,

    Sorry for disturbing you.. I just have these issues which I posted here too:
    https://github.com/Themekraft/Custom-Community/issues/71

    It’s the following:

    1- There’s an issue regarding activity commenting in Buddypress which was solved in the last Buddypress update. The issue was: commenting directly after posting on the activity stream, a redirection to “…/wp-admin/admin-ajax.php#ac-form-488″ white page with 0 displaying!
    The fix is in the bp-default theme. When I asked the buddypress team about it, they said I have to replace the _inc folder in my theme with the one in the budypress default theme but this triggered other issues :S so how this would be fixed?

    2- Threaded activity updates’ commenting is not working, it all appears in the same level!

    3- Commenting on an activity update refreshes the whole page while it would be away better to make it ajax commenting just like Buddypress default theme.

    Hope to fix these issues soon since it’s very important.

    Thanks
    Hope

  11. Clint says:

    I have a weird problem i am not seeing reported any where. I have a site where only 2 of my admins are getting 404 errors when they click on any link in the site that takes them to the buddypress profile pages, and no one else has this issue but these two. Any ideas?

Leave a Reply